CVE-2022-3715

NameCVE-2022-3715
DescriptionA flaw was found in the bash package, where a heap-buffer overflow can occur in valid parameter_transform. This issue may lead to memory problems.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1030355

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bash (PTS)buster5.0-4fixed
bullseye5.1-2+deb11u1vulnerable
bookworm5.2.15-2fixed
sid, trixie5.2.21-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bashsourcebuster(not affected)
bashsource(unstable)5.2-11030355

Notes

[bullseye] - bash <no-dsa> (Minor issue)
[buster] - bash <not-affected> (Vulnerable code introduced later)
https://bugzilla.redhat.com/show_bug.cgi?id=2126720
https://lists.gnu.org/archive/html/bug-bash/2022-08/msg00147.html
Introduced by: http://git.savannah.gnu.org/cgit/bash.git/commit/?id=bdf37a2d4f0f052ffd15d36de3b3a5d28f357000 (5.1)

Search for package or bug name: Reporting problems