CVE-2022-37436

NameCVE-2022-37436
DescriptionPrior to Apache HTTP Server 2.4.55, a malicious backend can cause the response headers to be truncated early, resulting in some headers being incorporated into the response body. If the later headers have any security purpose, they will not be interpreted by the client.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)buster2.4.38-3+deb10u8vulnerable
buster (security)2.4.38-3+deb10u7vulnerable
bullseye2.4.54-1~deb11u1vulnerable
bullseye (security)2.4.52-1~deb11u2vulnerable
bookworm, sid2.4.55-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.4.55-1

Notes

[bullseye] - apache2 <no-dsa> (Minor update; update proposed via bullseye-pu)
https://www.openwall.com/lists/oss-security/2023/01/17/7
https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2022-37436

Search for package or bug name: Reporting problems