CVE-2022-37451

NameCVE-2022-37451
DescriptionExim before 4.96 has an invalid free in pam_converse in auths/call_pam.c because store_free is not used after store_malloc.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)buster4.92-8+deb10u6fixed
buster (security)4.92-8+deb10u9fixed
bullseye (security), bullseye4.94.2-7+deb11u2fixed
bookworm, bookworm (security)4.96-15+deb12u4fixed
sid, trixie4.97-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exim4sourcebuster(not affected)
exim4sourcebullseye(not affected)
exim4source(unstable)4.95-4

Notes

[bullseye] - exim4 <not-affected> (Vulnerable code not present)
[buster] - exim4 <not-affected> (Vulnerable code not present)
https://github.com/ivd38/exim_invalid_free
https://github.com/Exim/exim/commit/51be321b27825c01829dffd90f11bfff256f7e42 (exim-4.96-RC0)
Introduced in https://github.com/Exim/exim/commit/1e30b0199daf7a7a882458251a3dc10d45d4c7d1 (exim-4.95-RC0)

Search for package or bug name: Reporting problems