CVE-2022-37616

NameCVE-2022-37616
Description** DISPUTED ** A prototype pollution vulnerability exists in the function copy in dom.js in the xmldom (published as @xmldom/xmldom) package before 0.8.3 for Node.js via the p variable. NOTE: the vendor states "we are in the process of marking this report as invalid."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3154-1
Debian Bugs1021618

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-xmldom (PTS)buster0.1.27+ds-1vulnerable
buster (security)0.1.27+ds-1+deb10u1fixed
bullseye0.5.0-1vulnerable
bookworm, sid0.8.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-xmldomsourcebuster0.1.27+ds-1+deb10u1DLA-3154-1
node-xmldomsource(unstable)0.8.3-11021618

Notes

[bullseye] - node-xmldom <no-dsa> (Minor issue)
https://github.com/xmldom/xmldom/issues/436
https://github.com/xmldom/xmldom/security/advisories/GHSA-9pgh-qqpf-7wqj
Fixed by: https://github.com/xmldom/xmldom/commit/6956ec406fd4658dfb028a327c7a39238b24c3cd (0.9.0-beta.2)
Fixed by: https://github.com/xmldom/xmldom/commit/7c0d4b7fbf74079060a2f135a369adeeccaf4b18 (0.8.3)

Search for package or bug name: Reporting problems