CVE-2022-38065

NameCVE-2022-38065
DescriptionA privilege escalation vulnerability exists in the oslo.privsep functionality of OpenStack git master 05194e7618 and prior. Overly permissive functionality within tools leveraging this library within a container can lead increased privileges.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-oslo.privsep (PTS)buster1.29.0-2vulnerable
bullseye2.4.0-2vulnerable
bookworm, sid3.0.1-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-oslo.privsepsource(unstable)(unfixed)

Notes

https://talosintelligence.com/vulnerability_reports/TALOS-2022-1599
check details

Search for package or bug name: Reporting problems