CVE-2022-3854

NameCVE-2022-3854
DescriptionA flaw was found in Ceph, relating to the URL processing on RGW backends. An attacker can exploit the URL processing by providing a null URL to crash the RGW, causing a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1027151

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ceph (PTS)buster12.2.11+dfsg1-2.1fixed
buster (security)12.2.11+dfsg1-2.1+deb10u1fixed
bullseye14.2.21-1fixed
bookworm16.2.11+ds-2fixed
sid, trixie18.2.3+ds-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cephsourcebuster(not affected)
cephsourcebullseye(not affected)
cephsource(unstable)16.2.10+ds-51027151

Notes

[bullseye] - ceph <not-affected> (Vulnerable code added in Ceph 16.1)
[buster] - ceph <not-affected> (Vulnerable code added in Ceph 16.1)
https://bugzilla.redhat.com/show_bug.cgi?id=2139925
https://bugzilla.suse.com/show_bug.cgi?id=1205025
https://tracker.ceph.com/issues/55765
https://github.com/ceph/ceph/pull/47025
Introduced in https://github.com/ceph/ceph/commit/99f7c4aa1286edfea6961b92bb44bb8fe22bd599

Search for package or bug name: Reporting problems