CVE-2022-38851

NameCVE-2022-38851
DescriptionCertain The MPlayer Project products are vulnerable to Out-of-bounds Read via function read_meta_record() of mplayer/libmpdemux/asfheader.c. This affects mplayer SVN-r38374-13.0.1 and mencoder SVN-r38374-13.0.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3255-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mplayer (PTS)buster2:1.3.0-8vulnerable
buster (security)2:1.3.0-8+deb10u1fixed
bullseye2:1.4+ds1-1+deb11u1fixed
bookworm2:1.5+svn38408-1fixed
sid, trixie2:1.5+svn38423-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mplayersourcebuster2:1.3.0-8+deb10u1DLA-3255-1
mplayersourcebullseye2:1.4+ds1-1+deb11u1
mplayersource(unstable)2:1.5+svn38408-1unimportant

Notes

https://trac.mplayerhq.hu/ticket/2393
https://git.ffmpeg.org/gitweb/mplayer.git/commit/58db9292a414ebf13a2cacdb3ffa967fb9036935 (r38382)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems