CVE-2022-39047

NameCVE-2022-39047
DescriptionFreeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the Modpack Installer utility's handling of the modpack URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1017579

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeciv (PTS)buster2.6.0-2vulnerable
bullseye2.6.3-1vulnerable
bookworm, sid3.0.3-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freecivsource(unstable)3.0.3-11017579

Notes

[bullseye] - freeciv <no-dsa> (Minor issue)
[buster] - freeciv <no-dsa> (Minor issue)
https://osdn.net/projects/freeciv/ticket/45299
https://www.openwall.com/lists/oss-security/2022/08/05/1

Search for package or bug name: Reporting problems