CVE-2022-39261

NameCVE-2022-39261
DescriptionTwig is a template language for PHP. Versions 1.x prior to 1.44.7, 2.x prior to 2.15.3, and 3.x prior to 3.4.3 encounter an issue when the filesystem loader loads templates for which the name is a user input. It is possible to use the `source` or `include` statement to read arbitrary files from outside the templates' directory when using a namespace like `@somewhere/../some.file`. In such a case, validation is bypassed. Versions 1.44.7, 2.15.3, and 3.4.3 contain a fix for validation of such template names. There are no known workarounds aside from upgrading.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3147-1, DSA-5248-1
Debian Bugs1020991

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-twig (PTS)bullseye2.14.3-1+deb11u1vulnerable
bullseye (security)2.14.3-1+deb11u2fixed
bookworm, sid3.4.3-1fixed
twig (PTS)buster2.6.2-2vulnerable
buster (security)2.6.2-2+deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-twigsourcebullseye2.14.3-1+deb11u2DSA-5248-1
php-twigsource(unstable)3.4.3-11020991
twigsourcebuster2.6.2-2+deb10u1DLA-3147-1
twigsource(unstable)(unfixed)

Notes

https://github.com/twigphp/Twig/security/advisories/GHSA-52m2-vc4m-jj33
https://github.com/twigphp/Twig/commit/35f3035c5deb0041da7b84daf02dea074ddc7a0b (v1.44.7, v2.15.3, v3.4.3)

Search for package or bug name: Reporting problems