CVE-2022-39286

NameCVE-2022-39286
DescriptionJupyter Core is a package for the core common functionality of Jupyter projects. Jupyter Core prior to version 4.11.2 contains an arbitrary code execution vulnerability in `jupyter_core` that stems from `jupyter_core` executing untrusted files in CWD. This vulnerability allows one user to run code as another. Version 4.11.2 contains a patch for this issue. There are no known workarounds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3195-1
Debian Bugs1023361

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jupyter-core (PTS)buster4.4.0-2vulnerable
buster (security)4.4.0-2+deb10u1fixed
bullseye4.7.1-1vulnerable
bookworm, sid4.11.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jupyter-coresourcebuster4.4.0-2+deb10u1DLA-3195-1
jupyter-coresource(unstable)4.11.2-11023361

Notes

https://github.com/jupyter/jupyter_core/security/advisories/GHSA-m678-f26j-3hrp
https://github.com/jupyter/jupyter_core/commit/1118c8ce01800cb689d51f655f5ccef19516e283 (4.11.2)

Search for package or bug name: Reporting problems