CVE-2022-40188

NameCVE-2022-40188
DescriptionKnot Resolver before 5.5.3 allows remote attackers to cause a denial of service (CPU consumption) because of algorithmic complexity. During an attack, an authoritative server must return large NS sets or address sets.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3139-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
knot-resolver (PTS)buster3.2.1-3vulnerable
buster (security)3.2.1-3+deb10u2fixed
bullseye5.3.1-1+deb11u1vulnerable
bookworm5.6.0-1fixed
bookworm (security)5.6.0-1+deb12u1fixed
sid, trixie5.7.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
knot-resolversourcebuster3.2.1-3+deb10u1DLA-3139-1
knot-resolversource(unstable)5.5.3-1

Notes

[bullseye] - knot-resolver <no-dsa> (Minor issue)
https://github.com/CZ-NIC/knot-resolver/commit/f6577a20e493c7fbdac124d7544bf1846b084185 (v5.5.3)
https://www.knot-resolver.cz/2022-09-21-knot-resolver-5.5.3.html

Search for package or bug name: Reporting problems