CVE-2022-40320

NameCVE-2022-40320
Descriptioncfg_tilde_expand in confuse.c in libConfuse 3.3 has a heap-based buffer over-read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1019596

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libconfuse (PTS)bullseye3.3-2vulnerable
bookworm, sid3.3-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libconfusesource(unstable)3.3-31019596

Notes

[bullseye] - libconfuse <no-dsa> (Minor issue)
https://github.com/libconfuse/libconfuse/issues/163
Fixed by: https://github.com/libconfuse/libconfuse/commit/d73777c2c3566fb2647727bb56d9a2295b81669b

Search for package or bug name: Reporting problems