CVE-2022-40468

NameCVE-2022-40468
DescriptionTinyproxy commit 84f203f and earlier does not process HTTP request lines in the process_request() function and is using uninitialized buffers. This vulnerability allows attackers to access sensitive information at system runtime.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1021015

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tinyproxy (PTS)buster1.10.0-2+deb10u1vulnerable
bullseye1.10.0-5vulnerable
bookworm1.11.1-1vulnerable
sid1.11.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tinyproxysource(unstable)1.11.1-21021015

Notes

[bullseye] - tinyproxy <no-dsa> (Minor issue)
https://github.com/tinyproxy/tinyproxy/issues/457
https://github.com/tinyproxy/tinyproxy/commit/3764b8551463b900b5b4e3ec0cd9bb9182191cb7

Search for package or bug name: Reporting problems