CVE-2022-40674

NameCVE-2022-40674
Descriptionlibexpat before 2.4.9 has a use-after-free in the doContent function in xmlparse.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3119-1, DSA-5236-1
Debian Bugs1019761

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
expat (PTS)buster2.2.6-2+deb10u4vulnerable
buster (security)2.2.6-2+deb10u5fixed
bullseye2.2.10-2+deb11u3vulnerable
bullseye (security)2.2.10-2+deb11u4fixed
bookworm, sid2.4.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
expatsourcebuster2.2.6-2+deb10u5DLA-3119-1
expatsourcebullseye2.2.10-2+deb11u4DSA-5236-1
expatsource(unstable)2.4.8-21019761

Notes

https://github.com/libexpat/libexpat/pull/629
https://github.com/libexpat/libexpat/pull/640
https://github.com/libexpat/libexpat/commit/4a32da87e931ba54393d465bb77c40b5c33d343b

Search for package or bug name: Reporting problems