CVE-2022-41322

NameCVE-2022-41322
DescriptionIn Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1020582

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kitty (PTS)buster, buster (security)0.13.3-1+deb10u1vulnerable
bullseye0.19.3-1vulnerable
bookworm, sid0.21.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kittysource(unstable)0.21.2-21020582

Notes

[bullseye] - kitty <no-dsa> (Minor issue)
[buster] - kitty <no-dsa> (Minor issue)
https://github.com/kovidgoyal/kitty/commit/f05783e64d5fa62e1aed603e8d69aced5e49824f (v0.26.2)

Search for package or bug name: Reporting problems