CVE-2022-41323

NameCVE-2022-41323
DescriptionIn Django 3.2 before 3.2.16, 4.0 before 4.0.8, and 4.1 before 4.1.2, internationalized URLs were subject to a potential denial of service attack via the locale parameter, which is treated as a regular expression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5254-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)buster1:1.11.29-1~deb10u1fixed
buster (security)1:1.11.29-1+deb10u5fixed
bullseye2:2.2.26-1~deb11u1vulnerable
bullseye (security)2:2.2.28-1~deb11u1fixed
bookworm, sid3:3.2.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosourcebuster(not affected)
python-djangosourcebullseye2:2.2.28-1~deb11u1DSA-5254-1
python-djangosource(unstable)3:3.2.16-1

Notes

[buster] - python-django <not-affected> (Vulnerable code not present)
https://www.djangoproject.com/weblog/2022/oct/04/security-releases/
https://www.openwall.com/lists/oss-security/2022/10/04/2
https://github.com/django/django/commit/e5ea2842941967f06cefa10865f303b39c95279f (main)
https://github.com/django/django/commit/9d656ea51d9ea7105c0c0785783ac29d426a7d25 (4.1.2)
https://github.com/django/django/commit/5b6b257fa7ec37ff27965358800c67e2dd11c924 (3.2.16)

Search for package or bug name: Reporting problems