CVE-2022-41444

NameCVE-2022-41444
DescriptionCross Site Scripting (XSS) vulnerability in Cacti 1.2.21 via crafted POST request to graphs_new.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)buster1.2.2+ds1-2+deb10u4fixed
buster (security)1.2.2+ds1-2+deb10u5fixed
bullseye (security), bullseye1.2.16+ds1-2+deb11u2vulnerable
bookworm, bookworm (security)1.2.24+ds1-1+deb12u1fixed
trixie, sid1.2.26+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisourcebuster(not affected)
cactisource(unstable)1.2.22+ds1-1

Notes

[bullseye] - cacti <no-dsa> (Minor issue)
[buster] - cacti <not-affected> (Vulnerable code introduced later)
https://gist.github.com/enferas/9079535112e4f4ff2c1d2ce1c099d4c2
Fixed by: https://github.com/Cacti/cacti/commit/ccb8b62de0f27f59d5e6073c2ae577a9ca7adaf8 (release/1.2.22)
Introduced by: https://github.com/Cacti/cacti/commit/572a3654c7efdbf82ad540f163438a1ba7c4b8bf (release/1.2.6)

Search for package or bug name: Reporting problems