CVE-2022-41727

NameCVE-2022-41727
DescriptionAn attacker can craft a malformed TIFF image which will consume a significant amount of memory when passed to DecodeConfig. This could lead to a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-golang-x-image (PTS)buster0.0~git20190321.3fc05d4+really0.0~git20181116.cd38e80-1vulnerable
bullseye0.0~git20200119.58c2397-1vulnerable
bookworm0.5.0-1fixed
sid, trixie0.16.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-golang-x-imagesource(unstable)0.5.0-1

Notes

[bullseye] - golang-golang-x-image <no-dsa> (Minor issue)
[buster] - golang-golang-x-image <postponed> (Limited support, minor issue, DoS)

Search for package or bug name: Reporting problems