Descriptionmultipath-tools 0.7.0 through 0.9.x before 0.9.2 allows local users to obtain root access, as exploited alone or in conjunction with CVE-2022-41973. Local users able to write to UNIX domain sockets can bypass access controls and manipulate the multipath setup. This can lead to local privilege escalation to root. This occurs because an attacker can repeat a keyword, which is mishandled because arithmetic ADD is used instead of bitwise OR.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3250-1, DSA-5366-1
Debian Bugs1022742

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
multipath-tools (PTS)buster0.7.9-3+deb10u1vulnerable
buster (security)0.7.9-3+deb10u2fixed
bullseye (security), bullseye0.8.5-2+deb11u1fixed
sid, trixie0.9.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs

Introduced by: (0.7.0)
Fix included in
Fixed by (merge): (0.9.2) (0.9.2) (0.9.2, CVE fix) (0.9.2) (0.9.2) (0.9.2)

Search for package or bug name: Reporting problems