CVE-2022-42004

NameCVE-2022-42004
DescriptionIn FasterXML jackson-databind before 2.13.4, resource exhaustion can occur because of a lack of a check in BeanDeserializer._deserializeFromArray to prevent use of deeply nested arrays. An application is vulnerable only with certain customized choices for deserialization.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3207-1, DSA-5283-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jackson-databind (PTS)buster2.9.8-3+deb10u3vulnerable
buster (security)2.9.8-3+deb10u4fixed
bullseye2.12.1-1vulnerable
bullseye (security)2.12.1-1+deb11u1fixed
bookworm, sid2.14.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jackson-databindsourcebuster2.9.8-3+deb10u4DLA-3207-1
jackson-databindsourcebullseye2.12.1-1+deb11u1DSA-5283-1
jackson-databindsource(unstable)2.14.0-1

Notes

https://github.com/FasterXML/jackson-databind/issues/3582
https://github.com/FasterXML/jackson-databind/commit/063183589218fec19a9293ed2f17ec53ea80ba88 (jackson-databind-2.13.4)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=50490

Search for package or bug name: Reporting problems