CVE-2022-42011

NameCVE-2022-42011
DescriptionAn issue was discovered in D-Bus before 1.12.24, 1.13.x and 1.14.x before 1.14.4, and 1.15.x before 1.15.2. An authenticated attacker can cause dbus-daemon and other programs that use libdbus to crash when receiving a message where an array length is inconsistent with the size of the element type.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3142-1, DSA-5250-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dbus (PTS)buster1.12.20-0+deb10u1vulnerable
buster (security)1.12.24-0+deb10u1fixed
bullseye1.12.20-2vulnerable
bullseye (security)1.12.24-0+deb11u1fixed
bookworm, sid1.14.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dbussourcebuster1.12.24-0+deb10u1DLA-3142-1
dbussourcebullseye1.12.24-0+deb11u1DSA-5250-1
dbussource(unstable)1.14.4-1

Notes

https://www.openwall.com/lists/oss-security/2022/10/06/1
Fixed by: https://gitlab.freedesktop.org/dbus/dbus/-/commit/079bbf16186e87fb0157adf8951f19864bc2ed69

Search for package or bug name: Reporting problems