CVE-2022-4293

NameCVE-2022-4293
DescriptionFloating Point Comparison with Incorrect Operator in GitHub repository vim/vim prior to 9.0.0804.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
buster (security)2:8.1.0875-5+deb10u4vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm, sid2:9.0.1000-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)2:9.0.0813-1unimportant

Notes

https://huntr.dev/bounties/385a835f-6e33-4d00-acce-ac99f3939143
https://github.com/vim/vim/commit/cdef1cefa2a440911c727558562f83ed9b00e16b (v9.0.0804)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems