CVE-2022-43597

NameCVE-2022-43597
DescriptionMultiple memory corruption vulnerabilities exist in the IFFOutput alignment padding functionality of OpenImageIO Project OpenImageIO v2.4.4.2. A specially crafted ImageOutput Object can lead to arbitrary code execution. An attacker can provide malicious input to trigger these vulnerabilities.This vulnerability arises when the `m_spec.format` is `TypeDesc::UINT8`.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3382-1, DSA-5384-1
Debian Bugs1027143

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openimageio (PTS)buster2.0.5~dfsg0-1vulnerable
buster (security)2.0.5~dfsg0-1+deb10u2fixed
bullseye (security), bullseye2.2.10.1+dfsg-1+deb11u1fixed
bookworm2.4.7.1+dfsg-2fixed
sid2.5.12.0+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openimageiosourcebuster2.0.5~dfsg0-1+deb10u1DLA-3382-1
openimageiosourcebullseye2.2.10.1+dfsg-1+deb11u1DSA-5384-1
openimageiosource(unstable)2.4.7.1+dfsg-21027143

Notes

https://talosintelligence.com/vulnerability_reports/TALOS-2022-1655
https://github.com/OpenImageIO/oiio/pull/3676

Search for package or bug name: Reporting problems