CVE-2022-43705

NameCVE-2022-43705
DescriptionIn Botan before 2.19.3, it is possible to forge OCSP responses due to a certificate verification error. This issue was introduced in Botan 1.11.34 (November 2016).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
botan (PTS)bullseye2.17.3+dfsg-2vulnerable
bookworm2.19.3+dfsg-1fixed
sid, trixie2.19.5+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
botansource(unstable)2.19.3+dfsg-1

Notes

[bullseye] - botan <no-dsa> (Minor issue)
[buster] - botan <no-dsa> (Minor issue)
https://github.com/randombit/botan/security/advisories/GHSA-4v9w-qvcq-6q7w
https://github.com/randombit/botan/commit/fd83d9e262f63fb673e4c13ca37e5b768e41e812 (2.19.3)
https://github.com/randombit/botan/commit/4e35073ff356e37c3adcf1ff3522e9d0d48c765f (2.19.3)
https://github.com/randombit/botan/commit/c2faa88b0281e5017be72e1c85d0c41f686e1928 (2.19.3)
https://github.com/randombit/botan/commit/5d8d9fbf75c8b814ea609161bee525d520f5cb57 (2.19.3)
https://github.com/randombit/botan/commit/1829ef9d89614da1eacdf511356bdf98a970f5f5 (2.19.3)
https://github.com/randombit/botan/commit/991b0159282781f2d5c06ff42a9ff00ee563e96b (2.19.3)
https://github.com/randombit/botan/commit/a33689613127f319c0047fb96f092de16e7cb350 (2.19.3)
https://github.com/randombit/botan/commit/909c62717855402e04dbaf8ffc085f444d547aae (2.19.3)

Search for package or bug name: Reporting problems