CVE-2022-44267

NameCVE-2022-44267
DescriptionImageMagick 7.1.0-49 is vulnerable to Denial of Service. When it parses a PNG image (e.g., for resize), the convert process could be left waiting for stdin input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3357-1, DSA-5347-1
Debian Bugs1030767

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)buster8:6.9.10.23+dfsg-2.1+deb10u1vulnerable
buster (security)8:6.9.10.23+dfsg-2.1+deb10u5fixed
bullseye, bullseye (security)8:6.9.11.60+dfsg-1.3+deb11u1fixed
bookworm, sid8:6.9.11.60+dfsg-1.6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksourcebuster8:6.9.10.23+dfsg-2.1+deb10u2DLA-3357-1
imagemagicksourcebullseye8:6.9.11.60+dfsg-1.3+deb11u1DSA-5347-1
imagemagicksource(unstable)8:6.9.11.60+dfsg-1.61030767

Notes

https://github.com/ImageMagick/ImageMagick6/commit/d77c01e560e973177feed4915ffd7dd1a45fd763
https://www.metabaseq.com/imagemagick-zero-days/
https://github.com/ImageMagick/ImageMagick/discussions/6027

Search for package or bug name: Reporting problems