CVE-2022-45059

NameCVE-2022-45059
DescriptionAn issue was discovered in Varnish Cache 7.x before 7.1.2 and 7.2.x before 7.2.1. A request smuggling attack can be performed on Varnish Cache servers by requesting that certain headers are made hop-by-hop, preventing the Varnish Cache servers from forwarding critical headers to the backend.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1023750

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
varnish (PTS)buster6.1.1-1+deb10u3fixed
buster (security)6.1.1-1+deb10u4fixed
bullseye (security), bullseye6.5.1-1+deb11u2fixed
bookworm, sid7.1.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
varnishsourcebuster(not affected)
varnishsourcebullseye(not affected)
varnishsource(unstable)(unfixed)1023750

Notes

[bullseye] - varnish <not-affected> (Vulnerable code not present, only affects Varnish 7)
[buster] - varnish <not-affected> (Vulnerable code not present, only affects Varnish 7)
https://varnish-cache.org/security/VSV00010.html
https://github.com/varnishcache/varnish-cache/commit/fcf5722af75fdbf58dd425dd68d0beaa49bab4f4

Search for package or bug name: Reporting problems