CVE-2022-45198

NameCVE-2022-45198
DescriptionPillow before 9.2.0 performs Improper Handling of Highly Compressed GIF Data (Data Amplification).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)buster5.4.1-2+deb10u3vulnerable
buster (security)5.4.1-2+deb10u4vulnerable
bullseye (security), bullseye8.1.2+dfsg-0.3+deb11u1vulnerable
bookworm9.4.0-1.1fixed
sid, trixie10.2.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsource(unstable)9.2.0-1

Notes

[bullseye] - pillow <no-dsa> (Minor issue)
[buster] - pillow <no-dsa> (Minor issue)
https://github.com/python-pillow/Pillow/commit/11918eac0628ec8ac0812670d9838361ead2d6a4 (9.2.0)
https://github.com/python-pillow/Pillow/pull/6402

Search for package or bug name: Reporting problems