CVE-2022-46663

NameCVE-2022-46663
DescriptionIn GNU Less before 609, crafted data can result in "less -R" not filtering ANSI escape sequences sent to the terminal.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1030825

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
less (PTS)buster487-0.1fixed
bullseye551-2fixed
sid, trixie, bookworm590-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lesssourcebuster(not affected)
lesssourcebullseye(not affected)
lesssource(unstable)590-1.21030825

Notes

[bullseye] - less <not-affected> (Vulnerable code not present)
[buster] - less <not-affected> (Vulnerable code not present)
https://www.openwall.com/lists/oss-security/2023/02/07/7
Introduced by: https://github.com/gwsw/less/commit/0f810ef16781bf0f59690be63af876bddabf68bf (v566)
Fixed by: https://github.com/gwsw/less/commit/a78e1351113cef564d790a730d657a321624d79c

Search for package or bug name: Reporting problems