CVE-2022-46698

NameCVE-2022-46698
DescriptionA logic issue was addressed with improved checks. This issue is fixed in Safari 16.2, tvOS 16.2, iCloud for Windows 14.1, macOS Ventura 13.1, iOS 16.2 and iPadOS 16.2, watchOS 9.2. Processing maliciously crafted web content may disclose sensitive user information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3274-1, DSA-5308-1, DSA-5309-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.36.4-1~deb10u1vulnerable
buster (security)2.38.4-2~deb10u1fixed
bullseye2.38.2-1~deb11u1vulnerable
bullseye (security)2.38.4-2~deb11u1fixed
bookworm2.38.3-1fixed
sid2.38.4-2fixed
wpewebkit (PTS)bullseye2.38.2-1~deb11u1vulnerable
bullseye (security)2.38.4-1~deb11u1fixed
bookworm, sid2.38.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster2.38.3-1~deb10u1DLA-3274-1
webkit2gtksourcebullseye2.38.3-1~deb11u1DSA-5308-1
webkit2gtksource(unstable)2.38.3-1
wpewebkitsourcebullseye2.38.3-1~deb11u1DSA-5309-1
wpewebkitsource(unstable)2.38.3-1

Notes

https://webkitgtk.org/security/WSA-2022-0011.html

Search for package or bug name: Reporting problems