CVE-2022-46908

NameCVE-2022-46908
DescriptionSQLite through 3.40.0, when relying on --safe for execution of an untrusted CLI script, does not properly implement the azProhibitedFunctions protection mechanism, and instead allows UDF functions such as WRITEFILE.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1026293

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlite (PTS)buster2.8.17-15fixed
buster (security)2.8.17-15+deb10u1fixed
sqlite3 (PTS)buster3.27.2-3+deb10u1fixed
buster (security)3.27.2-3+deb10u2fixed
bullseye3.34.1-3fixed
bookworm3.40.1-2fixed
trixie3.45.1-1fixed
sid3.45.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlitesource(unstable)(not affected)
sqlite3sourcebuster(not affected)
sqlite3sourcebullseye(not affected)
sqlite3source(unstable)3.40.0-21026293

Notes

[bullseye] - sqlite3 <not-affected> (Vulnerable code introduced later)
[buster] - sqlite3 <not-affected> (Vulnerable code introduced later)
- sqlite <not-affected> (--safe introduced in v3.36.0)
https://sqlite.org/forum/forumpost/07beac8056151b2f
Fixed by: https://sqlite.org/src/info/cefc032473ac5ad2

Search for package or bug name: Reporting problems