CVE-2022-4696

NameCVE-2022-4696
DescriptionThere exists a use-after-free vulnerability in the Linux kernel through io_uring and the IORING_OP_SPLICE operation. If IORING_OP_SPLICE is missing the IO_WQ_WORK_FILES flag, which signals that the operation won't use current->nsproxy, so its reference counter is not increased. This assumption is not always true as calling io_splice on specific files will call the get_uts function which will use current->nsproxy leading to invalidly decreasing its reference counter later causing the use-after-free vulnerability. We recommend upgrading to version 5.10.160 or above
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5324-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)buster4.19.249-2fixed
buster (security)4.19.269-1fixed
bullseye5.10.158-2vulnerable
bullseye (security)5.10.162-1fixed
bookworm6.1.7-1fixed
sid6.1.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcebuster(not affected)
linuxsourcebullseye5.10.162-1DSA-5324-1
linuxsource(unstable)5.14.6-1

Notes

[buster] - linux <not-affected> (Vulnerable code not present)
https://kernel.dance/#75454b4bbfc7e6a4dd8338556f36ea9107ddf61a

Search for package or bug name: Reporting problems