CVE-2022-47518

NameCVE-2022-47518
DescriptionAn issue was discovered in the Linux kernel before 6.0.11. Missing validation of the number of channels in drivers/net/wireless/microchip/wilc1000/cfg80211.c in the WILC1000 wireless driver can trigger a heap-based buffer overflow when copying the list of operating channels from Wi-Fi management frames.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3244-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)buster4.19.249-2vulnerable
buster (security)4.19.269-1vulnerable
bullseye5.10.158-2fixed
bullseye (security)5.10.162-1fixed
bookworm6.1.7-1fixed
sid6.1.8-1fixed
linux-5.10 (PTS)buster (security)5.10.158-2~deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcebullseye5.10.158-1
linuxsource(unstable)6.0.12-1
linux-5.10sourcebuster5.10.158-2~deb10u1DLA-3244-1

Notes

https://git.kernel.org/linus/0cdfa9e6f0915e3d243e2393bfa8a22e12d553b0

Search for package or bug name: Reporting problems