CVE-2022-47673

NameCVE-2022-47673
DescriptionAn issue was discovered in Binutils addr2line before 2.39.3, function parse_module contains multiple out of bound reads which may cause a denial of service or other unspecified impacts.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
binutils (PTS)bullseye2.35.2-2vulnerable
bookworm2.40-2fixed
sid, trixie2.42.50.20240710-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
binutilssource(unstable)2.39.50.20221224-1unimportant

Notes

https://sourceware.org/bugzilla/show_bug.cgi?id=29876
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=77c225bdeb410cf60da804879ad41622f5f1aa44
binutils not covered by security support

Search for package or bug name: Reporting problems