CVE-2022-47950

NameCVE-2022-47950
DescriptionAn issue was discovered in OpenStack Swift before 2.28.1, 2.29.x before 2.29.2, and 2.30.0. By supplying crafted XML files, an authenticated user may coerce the S3 API into returning arbitrary file contents from the host server, resulting in unauthorized read access to potentially sensitive data. This impacts both s3api deployments (Rocky or later), and swift3 deployments (Queens and earlier, no longer actively developed).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3281-1, DSA-5327-1
Debian Bugs1029154

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
swift (PTS)buster2.19.1-1vulnerable
buster (security)2.19.1-1+deb10u1fixed
bullseye (security), bullseye2.26.0-10+deb11u1fixed
bookworm2.30.0-4fixed
sid, trixie2.32.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
swiftsourcebuster2.19.1-1+deb10u1DLA-3281-1
swiftsourcebullseye2.26.0-10+deb11u1DSA-5327-1
swiftsource(unstable)2.30.0-41029154

Notes

https://www.openwall.com/lists/oss-security/2023/01/17/1

Search for package or bug name: Reporting problems