CVE-2022-48279

NameCVE-2022-48279
DescriptionIn ModSecurity before 2.9.6 and 3.x before 3.0.8, HTTP multipart requests were incorrectly parsed and could bypass the Web Application Firewall. NOTE: this is related to CVE-2022-39956 but can be considered independent changes to the ModSecurity (C language) codebase.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3283-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
modsecurity (PTS)buster, buster (security)3.0.3-1+deb10u2vulnerable
bullseye3.0.4-2vulnerable
bookworm, sid3.0.8-1fixed
modsecurity-apache (PTS)buster2.9.3-1+deb10u1vulnerable
buster (security)2.9.3-1+deb10u2fixed
bullseye (security), bullseye2.9.3-3+deb11u1vulnerable
bookworm, sid2.9.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
modsecuritysource(unstable)3.0.8-1
modsecurity-apachesourcebuster2.9.3-1+deb10u2DLA-3283-1
modsecurity-apachesource(unstable)2.9.6-1

Notes

[bullseye] - modsecurity-apache <no-dsa> (Minor issue)
[bullseye] - modsecurity <no-dsa> (Minor issue)
[buster] - modsecurity <no-dsa> (Minor issue)
https://coreruleset.org/20220919/crs-version-3-3-3-and-3-2-2-covering-several-cves/
https://github.com/SpiderLabs/ModSecurity/pull/2795
Fixed by: https://github.com/SpiderLabs/ModSecurity/commit/d6c10885e08779e99e76efcd5ad65802104cda14 (v3.0.8)
https://github.com/SpiderLabs/ModSecurity/pull/2797
Fixed by: https://github.com/SpiderLabs/ModSecurity/commit/51a30d7b406af95c4143560d9753cf0b6d2151f5 (v2.9.6)
Issue relates to CVE-2022-39956 but considered independent change to ModSecurity (C
language) codebase.

Search for package or bug name: Reporting problems