CVE-2022-48338

NameCVE-2022-48338
DescriptionAn issue was discovered in GNU Emacs through 28.2. In ruby-mode.el, the ruby-find-library-file function has a local command injection vulnerability. The ruby-find-library-file function is an interactive function, and bound to C-c C-f. Inside the function, the external command gem is called through shell-command-to-string, but the feature-name parameters are not escaped. Thus, malicious Ruby source files may cause commands to be executed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5360-1
Debian Bugs1031730

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
emacs (PTS)buster1:26.1+1-3.2+deb10u2fixed
buster (security)1:26.1+1-3.2+deb10u5fixed
bullseye1:27.1+1-3.1+deb11u1vulnerable
bullseye (security)1:27.1+1-3.1+deb11u2fixed
bookworm1:28.2+1-15fixed
trixie1:29.3+1-3fixed
sid1:29.4+1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
emacssourcebuster(not affected)
emacssourcebullseye1:27.1+1-3.1+deb11u2DSA-5360-1
emacssource(unstable)1:28.2+1-111031730

Notes

[buster] - emacs <not-affected> (Vulnerable code introduced later)
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=60268
Introduced by: https://git.savannah.gnu.org/cgit/emacs.git/commit/?id=27f5627104a073762c3b1d21e55822ec2d2e0347 (emacs-27.0.90)
Fixed by: https://git.savannah.gnu.org/cgit/emacs.git/commit/?id=9a3b08061feea14d6f37685ca1ab8801758bfd1c

Search for package or bug name: Reporting problems