CVE-2022-48522

NameCVE-2022-48522
DescriptionIn Perl 5.34.0, function S_find_uninit_var in sv.c has a stack-based crash that can lead to remote code execution or local privilege escalation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)buster5.28.1-6+deb10u1fixed
bullseye5.32.1-4+deb11u3fixed
bullseye (security)5.32.1-4+deb11u1fixed
bookworm5.36.0-7+deb12u1fixed
trixie, sid5.38.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
perlsourcebuster(not affected)
perlsourcebullseye(not affected)
perlsource(unstable)5.36.0-4unimportant

Notes

[bullseye] - perl <not-affected> (Vulnerable code introduced later)
[buster] - perl <not-affected> (Vulnerable code introduced later)
Might be related to https://bugs.launchpad.net/ubuntu/+source/perl/+bug/2032667
which is just a infinite recursion exhausting the stack, with negligible security
impact.
https://github.com/Perl/perl5/issues/19147
Fixed by: https://github.com/Perl/perl5/commit/23cca2d1f4544cb47f1124d98c308ce1f31f09a6 (v5.35.5)

Search for package or bug name: Reporting problems