CVE-2022-48570

NameCVE-2022-48570
DescriptionCrypto++ through 8.4 contains a timing side channel in ECDSA signature generation. Function FixedSizeAllocatorWithCleanup could write to memory outside of the allocation if the allocated memory was not 16-byte aligned. NOTE: this issue exists because the CVE-2019-14318 fix was intentionally removed for functionality reasons.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1059309

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcrypto++ (PTS)bullseye8.4.0-1vulnerable
bookworm8.7.0+git220824-1vulnerable
trixie, sid8.9.0-1.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcrypto++source(unstable)(unfixed)1059309

Notes

[bookworm] - libcrypto++ <no-dsa> (Minor issue)
[bullseye] - libcrypto++ <no-dsa> (Minor issue)
[buster] - libcrypto++ <no-dsa> (Minor issue)
Related issue: https://github.com/weidai11/cryptopp/issues/992
This issue exists because the CVE-2019-14318 fix was intentionally removed for
functionality reasons. To fix the issue a rewrite of the rewrite the Integer class
is required.

Search for package or bug name: Reporting problems