CVE-2022-48622

NameCVE-2022-48622
DescriptionIn GNOME GdkPixbuf (aka gdk-pixbuf) through 2.42.10, the ANI (Windows animated cursor) decoder encounters heap memory corruption (in ani_load_chunk in io-ani.c) when parsing chunks in a crafted .ani file. A crafted file could allow an attacker to overwrite heap metadata, leading to a denial of service or code execution attack. This occurs in gdk_pixbuf_set_option() in gdk-pixbuf.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1071265

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gdk-pixbuf (PTS)buster2.38.1+dfsg-1vulnerable
bullseye (security), bullseye2.42.2+dfsg-1+deb11u1vulnerable
bookworm2.42.10+dfsg-1vulnerable
sid, trixie2.42.12+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gdk-pixbufsource(unstable)2.42.12+dfsg-11071265

Notes

[bookworm] - gdk-pixbuf <postponed> (Revisit once fixed upstream)
[bullseye] - gdk-pixbuf <postponed> (Revisit once fixed upstream)
[buster] - gdk-pixbuf <postponed> (Minor issue, recheck when fixed upstream)
https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/issues/202
Fixed by: https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/commit/00c071dd11f723ca608608eef45cb1aa98da89cc (2.42.12)
Further improvements/hardenings:
https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/commit/d52134373594ff76614fb415125b0d1c723ddd56 (2.42.12)
https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/commit/91b8aa5cd8a0eea28acb51f0e121827ca2e7eb78 (2.42.12)

Search for package or bug name: Reporting problems