CVE-2023-0054

NameCVE-2023-0054
DescriptionOut-of-bounds Write in GitHub repository vim/vim prior to 9.0.1145.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3453-1
Debian Bugs1031875

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
buster (security)2:8.1.0875-5+deb10u6fixed
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm2:9.0.1378-2fixed
sid, trixie2:9.1.0496-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcebuster2:8.1.0875-5+deb10u5DLA-3453-1
vimsource(unstable)2:9.0.1378-11031875

Notes

[bullseye] - vim <no-dsa> (Minor issue)
https://huntr.dev/bounties/b289ee0f-fd16-4147-bd01-c6289c45e49d
https://github.com/vim/vim/commit/3ac1d97a1d9353490493d30088256360435f7731 (v9.0.1145)

Search for package or bug name: Reporting problems