CVE-2023-0414

NameCVE-2023-0414
DescriptionCrash in the EAP dissector in Wireshark 4.0.0 to 4.0.2 allows denial of service via packet injection or crafted capture file
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)buster2.6.20-0+deb10u4fixed
buster (security)2.6.20-0+deb10u2fixed
bullseye (security), bullseye3.4.10-0+deb11u1vulnerable
bookworm, sid4.0.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourcebuster(not affected)
wiresharksource(unstable)4.0.3-1

Notes

[bullseye] - wireshark <postponed> (Minor issue, fix along in future update)
[buster] - wireshark <not-affected> (Vulnerable code introduced later)
https://www.wireshark.org/security/wnpa-sec-2023-01.html
https://gitlab.com/wireshark/wireshark/-/issues/18622
introduced by https://gitlab.com/wireshark/wireshark/-/merge_requests/6838

Search for package or bug name: Reporting problems