|Description||Due to failure in validating the length provided by an attacker-crafted IEEE-C37.118 packet, Wireshark version 4.0.5 and prior, by default, is susceptible to a heap-based buffer overflow, and possibly code execution in the context of the process running Wireshark.|
|Source||CVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)|
Vulnerable and fixed packages
The table below lists information on source packages.
|bullseye (security), bullseye||3.4.10-0+deb11u1||vulnerable|
|bookworm, bookworm (security)||4.0.11-1~deb12u1||fixed|
The information below is based on the following data on fixed versions.
[bullseye] - wireshark <no-dsa> (Minor issue)
[buster] - wireshark <not-affected> (vulnerable code introduced in 3.2)
Introduced by: https://gitlab.com/wireshark/wireshark/-/commit/254502d765d11f1d97b15bc1c3ff06d38e049ef2 (v3.1.1)