CVE-2023-0668

NameCVE-2023-0668
DescriptionDue to failure in validating the length provided by an attacker-crafted IEEE-C37.118 packet, Wireshark version 4.0.5 and prior, by default, is susceptible to a heap-based buffer overflow, and possibly code execution in the context of the process running Wireshark.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5429-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)bullseye (security), bullseye3.4.10-0+deb11u1vulnerable
bookworm, bookworm (security)4.0.11-1~deb12u1fixed
trixie4.2.5-2fixed
sid4.2.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourceexperimental4.0.6-1~exp1
wiresharksourcebuster(not affected)
wiresharksourcebookworm4.0.6-1~deb12u1DSA-5429-1
wiresharksource(unstable)4.0.6-1

Notes

[bullseye] - wireshark <no-dsa> (Minor issue)
[buster] - wireshark <not-affected> (vulnerable code introduced in 3.2)
https://www.wireshark.org/security/wnpa-sec-2023-19.html
https://gitlab.com/wireshark/wireshark/-/issues/19087
Introduced by: https://gitlab.com/wireshark/wireshark/-/commit/254502d765d11f1d97b15bc1c3ff06d38e049ef2 (v3.1.1)

Search for package or bug name: Reporting problems