CVE-2023-1127

NameCVE-2023-1127
DescriptionDivide By Zero in GitHub repository vim/vim prior to 9.0.1367.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2fixed
buster (security)2:8.1.0875-5+deb10u6fixed
bullseye2:8.2.2434-3+deb11u1fixed
bookworm2:9.0.1378-2fixed
sid, trixie2:9.1.0016-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcebuster(not affected)
vimsourcebullseye(not affected)
vimsource(unstable)2:9.0.1378-1unimportant

Notes

[bullseye] - vim <not-affected> (Vulnerable code not present)
[buster] - vim <not-affected> (Vulnerable code not present)
https://huntr.dev/bounties/2d4d309e-4c96-415f-9070-36d0815f1beb
Introduced by: https://github.com/vim/vim/commit/8cf3459878198c5bb4a96f3c63214b2 (v9.0.0701)
Fixed by: https://github.com/vim/vim/commit/e0f869196930ef5f25a0ac41c9215b09c9ce2d3c (v9.0.1367)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems