CVE-2023-1192

NameCVE-2023-1192
DescriptionA use-after-free flaw was found in smb2_is_status_io_timeout() in CIFS in the Linux Kernel. After CIFS transfers response data to a system call, there are still local variable points to the memory region, and if the system call frees it faster than CIFS uses it, CIFS will access a free memory region, leading to a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)bullseye (security), bullseye5.10.218-1vulnerable
bookworm6.1.94-1fixed
bookworm (security)6.1.90-1fixed
sid, trixie6.9.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcebuster(not affected)
linuxsourcebookworm6.1.64-1
linuxsource(unstable)6.5.6-1

Notes

[buster] - linux <not-affected> (Vulnerable code not present)
https://bugzilla.redhat.com/show_bug.cgi?id=2154178

Search for package or bug name: Reporting problems