CVE-2023-1668

NameCVE-2023-1668
DescriptionA flaw was found in openvswitch (OVS). When processing an IP packet with protocol 0, OVS will install the datapath flow without the action modifying the IP header. This issue results (for both kernel and userspace datapath) in installing a datapath flow matching all IP protocols (nw_proto is wildcarded) for this flow, but with an incorrect action, possibly causing incorrect handling of other IP packets with a != 0 IP protocol that matches this dp flow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3410-1, DSA-5387-1
Debian Bugs1034042

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvswitch (PTS)buster2.10.7+ds1-0+deb10u1vulnerable
buster (security)2.10.7+ds1-0+deb10u5fixed
bullseye2.15.0+ds1-2+deb11u4fixed
bullseye (security)2.15.0+ds1-2+deb11u5fixed
bookworm3.1.0-2fixed
bookworm (security)3.1.0-2+deb12u1fixed
sid, trixie3.3.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvswitchsourcebuster2.10.7+ds1-0+deb10u4DLA-3410-1
openvswitchsourcebullseye2.15.0+ds1-2+deb11u4DSA-5387-1
openvswitchsource(unstable)3.1.0-21034042

Notes

https://www.openwall.com/lists/oss-security/2023/04/06/1
https://github.com/openvswitch/ovs/commit/61b39d8c4797f1b668e4d5e5350d639fca6082a9 (v3.1.1)
https://github.com/openvswitch/ovs/commit/f36509fd64e339ffd33593451099be6baa12ffe6 (v2.15.8)

Search for package or bug name: Reporting problems