CVE-2023-20212

NameCVE-2023-20212
DescriptionA vulnerability in the AutoIt module of ClamAV could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. This vulnerability is due to a logic error in the memory management of an affected device. An attacker could exploit this vulnerability by submitting a crafted AutoIt file to be scanned by ClamAV on the affected device. A successful exploit could allow the attacker to cause the ClamAV scanning process to restart unexpectedly, resulting in a DoS condition.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1050057

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
clamav (PTS)buster0.103.6+dfsg-0+deb10u1fixed
buster (security)0.103.9+dfsg-0+deb10u1fixed
bullseye0.103.10+dfsg-0+deb11u1fixed
bookworm1.0.3+dfsg-1~deb12u1fixed
trixie1.0.5+dfsg-1fixed
sid1.0.5+dfsg-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
clamavsourcebuster(not affected)
clamavsourcebullseye(not affected)
clamavsourcebookworm1.0.2+dfsg-1~deb12u1
clamavsource(unstable)1.0.2+dfsg-11050057

Notes

[bullseye] - clamav <not-affected> (only affects v1.0.0 and v1.0.1)
[buster] - clamav <not-affected> (only affects v1.0.0 and v1.0.1)
https://blog.clamav.net/2023/07/2023-08-16-releases.html

Search for package or bug name: Reporting problems