CVE-2023-20867

NameCVE-2023-20867
DescriptionA fully compromised ESXi host can force VMware Tools to fail to authenticate host-to-guest operations, impacting the confidentiality and integrity of the guest virtual machine.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3531-1, DSA-5493-1
Debian Bugs1037546

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
open-vm-tools (PTS)buster2:10.3.10-1+deb10u2vulnerable
buster (security)2:10.3.10-1+deb10u6fixed
bullseye (security), bullseye2:11.2.5-2+deb11u3fixed
bookworm, bookworm (security)2:12.2.0-1+deb12u2fixed
sid, trixie2:12.3.5-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
open-vm-toolssourcebuster2:10.3.10-1+deb10u4DLA-3531-1
open-vm-toolssourcebullseye2:11.2.5-2+deb11u2DSA-5493-1
open-vm-toolssourcebookworm2:12.2.0-1+deb12u1DSA-5493-1
open-vm-toolssource(unstable)2:12.2.5-11037546

Notes

https://www.vmware.com/security/advisories/VMSA-2023-0013.html
https://github.com/vmware/open-vm-tools/tree/CVE-2023-20867.patch

Search for package or bug name: Reporting problems