CVE-2023-20898

NameCVE-2023-20898
DescriptionGit Providers can read from the wrong environment because they get the same cache directory base name in Salt masters prior to 3005.2 or 3006.2. Anything that uses Git Providers with different environments can get garbage data or the wrong data, which can lead to wrongful data disclosure, wrongful executions, data corruption and/or crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1051504

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
salt (PTS)buster, buster (security)2018.3.4+dfsg1-6+deb10u3vulnerable
bullseye (security), bullseye3002.6+dfsg1-4+deb11u1vulnerable
sid3004.1+dfsg-2.2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
saltsourcebuster(unfixed)end-of-life
saltsource(unstable)(unfixed)1051504

Notes

[buster] - salt <end-of-life> (EOL in buster LTS)
https://saltproject.io/security-announcements/2023-08-10-advisory/

Search for package or bug name: Reporting problems