CVE-2023-24038

NameCVE-2023-24038
DescriptionThe HTML-StripScripts module through 1.06 for Perl allows _hss_attval_style ReDoS because of catastrophic backtracking for HTML content with certain style attributes.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3296-1
Debian Bugs1029400

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libhtml-stripscripts-perl (PTS)buster, bullseye1.06-1vulnerable
buster (security)1.06-1+deb10u1fixed
bookworm, sid1.06-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libhtml-stripscripts-perlsourcebuster1.06-1+deb10u1DLA-3296-1
libhtml-stripscripts-perlsource(unstable)1.06-41029400

Notes

https://github.com/clintongormley/perl-html-stripscripts/issues/3
https://github.com/clintongormley/perl-html-stripscripts/pull/4

Search for package or bug name: Reporting problems