CVE-2023-25514

NameCVE-2023-25514
DescriptionNVIDIA CUDA toolkit for Linux and Windows contains a vulnerability in cuobjdump, where an attacker may cause an out-of-bounds read by tricking a user into running cuobjdump on a malformed input file. A successful exploit of this vulnerability may lead to limited denial of service, code execution, and limited information disclosure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1034793, 1034799

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nvidia-cuda-toolkit (PTS)buster/non-free9.2.148-7+deb10u1vulnerable
bullseye/non-free11.2.2-3+deb11u3vulnerable
bookworm/non-free11.8.0-5~deb12u1vulnerable
trixie/non-free, sid/non-free12.1.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nvidia-cuda-toolkitsource(unstable)12.1.1-1unimportant1034793, 1034799

Notes

https://nvidia.custhelp.com/app/answers/detail/a_id/5456
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems